ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 3 replies, has 2 voices, and was last updated by  s3than 2 years, 11 months ago.

  • Creator
    Topic
  • #6381

    s3than
    Participant

    I’m receiving installation issues related to node.js

    The error on installation is the following.

    Generating require.js build config
    Running code optimizer
    [RuntimeException]
    sh: 1: node: not found
    oro:requirejs:build

    However on ubuntu I have nodejs installed
    nodejs -v
    v0.10.25

    It appears that ORO isn’t picking it up?

    I am unable to use the Installed Packages either as I receive an AJAX error I believe it may be related.

    Thank you

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #6403

    s3than
    Participant

    SOLVED – Resolution for this issue

    In Ubuntu as stated NodeJS uses nodejs rather then node as a program already exists with that name in apt-get.

    To resolve the issue during install set in the config.yml

    Currently a warning will still display but the install should work. I put up a pull request for a check based on the config.yml.

    #6413

    Jowo
    Participant

    Or you can symlink node to nodejs.

    #6414

    s3than
    Participant

    True, I’d rather solve the issue by using the application itself then by altering the system. Either way should have some documentation. I’ve sent through a pull request with the config.yml change in the readme.md but I think your answer should be added as well.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.