ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 10 replies, has 2 voices, and was last updated by msulima msulima 1 month, 2 weeks ago.

  • Creator
    Topic
  • #35833
    mikhailspotar
    mikhailspotar
    Participant

    Hi. I noticed, that i can’t create custom user role with access to workflows. I create user and assign to this user preinstalled role “Sales Manager” – everithing is OK workflows are accessable. But if i clone this role and assign to the same user new role “Copy of Sales Manager” – access to workflows is lost. No visible menu item and 403 error if i use direct URL. Has anyone same or simillar problem?
    Thx,
    Mikhail

Viewing 10 replies - 1 through 10 (of 10 total)
  • Author
    Replies
  • #35838
    mikhailspotar
    mikhailspotar
    Participant

    UPD: application platform has the same bahaviour. Both 2.3.0 version.

    #35842
    msulima
    msulima
    Oro Core

    Hi, mikhailspotar.

    I tried next steps:
    1. install fresh crm-application v.2.3.0
    2. create user ‘test’ with exist role ‘Sales Manager’
    3. login as ‘test’ user
    4. open page opportunity view page
    5. see and can click workflow buttons
    6. clone ‘Sales Manager’
    7. assign new role to ‘test’ user
    8. login as ‘test’ user
    9. open page opportunity view page

    And still I can see workflow steps and clock workflow buttons. Maybe I missed something? Please, help me to reproduce that bug and provide more information. Thank you.

    #35843
    mikhailspotar
    mikhailspotar
    Participant

    Hi, msulima.
    In the second step you use existing role. Here is difference try to create new role or clone existing one.
    My steps was:
    1. install fresh crm-application v.2.3.0
    2. create user ‘test’ with exist role ‘Sales Manager’
    3. login as ‘test’ user
    4. look to the menu “system” while being on the dashboard page – you see the line workflows.
    5. create new role ‘Copy of Sales Manager’ and assigned it to ‘test’ user (role ‘Sales Manager’ must be unchecked)
    6. relogin as ‘test’ user
    7. look to the menu “system” while being on the dashboard page – you don’t see the line workflows.
    8. try to use direct url $site/workflowdefinition you see “Forbidden” page.
    9. restore user role to preinstalled (‘Sales Manager’) and relogin – everithing is OK.
    P.S. The same steps can be reproduced in application platform with the same result.

    #35844
    mikhailspotar
    mikhailspotar
    Participant

    I can provide you creditentials to login to my server (there is nothing important there :-)) if needed.

    #35845
    msulima
    msulima
    Oro Core

    Let me check your steps to reproduce on my local environment.

    #35846
    msulima
    msulima
    Oro Core

    mikhailspotar, please check that your new role have permission view for Entity grid.
    You should have something like

    #35847
    mikhailspotar
    mikhailspotar
    Participant

    muslima, sorry to say this – but i have no such line in my Entity grid. I have only list of workflows with permissions for each of them, but no general line like on you picture. As i understand this line must be present in the Entity grid while role creation (like Account, Activity list, Attachment etc), right?

    #35848
    msulima
    msulima
    Oro Core

    Yes, you’re right.
    And I just checked role edit page on our demo environment and on it I see described problem. Looks like a bug. I will investigate little bit more and add it to our backlog.

    #35849
    mikhailspotar
    mikhailspotar
    Participant

    Thanks. I’ll wait for further results.

    #35850
    msulima
    msulima
    Oro Core

    Internal ID: BAP-15176

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.