ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 12 replies, has 5 voices, and was last updated by  stebcom 1 year, 3 months ago.

  • Creator
    Topic
  • #6859

    Remo Laubacher
    Participant

    I’ve been following two different tutorials but when I open the page at localhost, I only see a the toolbar on top but no menu entries, just a blank content.
    These are my steps:

    • git clone https://github.com/orocrm/platform-application.git oro-demo
    • cd oro-demo
    • create a mysql database with a name of your choice
    • php composer.phar install –prefer-dist –no-dev
    • enter the mysql credentials to connect to the database and the name of the database you’ve created
    • php app/console oro:install –env prod
    • php app/console generate:bundle –namespace=Ortic/DemoBundle
    • specify yml as your configuration format and confirm everything else
    • create a new file at src/Ortic/DemoBundle/Resources/config called navigation.yml and put the following content in it
    • in the same directory, open routing.yml and replace it with this content:
    • modify the controller to match this:
    • php app/console oro:navigation:init
    • php app/console cache:clear –env=prod

    Can anyone tell me what I did wrong? Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Author
    Replies
  • #6928

    Alexandr Smaga
    Participant

    Hello @remo_laubacher !

    I’ve tried to follow yours step by step guide and it works fine for me !
    Did you reload page via “F5” or change page via JS navigation ?
    Did you check in prod env or dev ? You cleared caches for prod, so it’s possible to be outdated for dev.

    #6931

    Remo Laubacher
    Participant

    Reloaded, changed browser, restarted webserver, cleared caches for dev, prod and whatever else I could find. I just get a toolbar and a white background, only “My User”, “My Emails” etc. are there but even those don’t work. When I click on them the background changes to a slightly gray colour but that’s it. No luck..

    #6932

    Alexandr Smaga
    Participant

    Hm… Could you please check log files ? It more looks like PHP error during menu generation.

    #6933

    Remo Laubacher
    Participant

    PHP, Apache and app/logs files are all empty. Any suggestions where I should start debugging?

    #6936
    Jaimy
    Jaimy
    Participant

    Hi Remo,

    Do you have xDebug enabled? If so, try upping the xdebug.max_nesting_level to 1000 or so. I’ve encountered this problem after I updated to Yosemite with Apache 2.4.9. Hope this helps!

    Kind Regards,

    Jaimy Casteleijn

    #6937

    Remo Laubacher
    Participant

    Thanks Jaimy, that works like a charm! Would have expected to see a log entry for such this problem, but it definitely helps!

    #6939
    Jaimy
    Jaimy
    Participant

    Hi Remo,

    It took me 2 days to finally find the solution ๐Ÿ˜‰ For some reason it doesn’t show immediately, but only displays at a certain level (couldn’t reproduce it unfortunately :<).
    Still glad it helped!

    Kind Regards,

    Jaimy Casteleijn

    #6940

    Remo Laubacher
    Participant

    yeah, not exactly my first thought to increase the nesting level ๐Ÿ˜‰ Might be worth adding a check during the installation process..?

    #6958
    Jaimy
    Jaimy
    Participant

    Didn’t expect it either, but I might be worth it to add it in the installation process or notes. I’ll leave that to the Oro team. I think it’s a rather good suggestion, let’s hope they like it as well ๐Ÿ™‚

    Kind Regards,

    Jaimy Casteleijn

    #15401

    stebcom
    Participant

    I’ve got the same problem: I created a new bundle without updating kernel and routes, following all the Cookbook instructions, but I cannot see anything I defined into navigation.yml file of my bundle.
    Did you find a solution for this issue?

    #15444

    Yurii Muratov
    Oro Core

    Hi, @stebcom.
    Please copy and paste here your navigation.yml file.

    • This reply was modified 1 year, 3 months ago by Ivan Klymenko Ivan Klymenko.
    #15448

    stebcom
    Participant

    Now it’s working! I didn’t make any changes actually, maybe the cache was not completely refreshed when I tried the other day. I don’t know why, because I always checked after executing

    Thanks anyway!

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.