ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 8 replies, has 3 voices, and was last updated by adriwan_kenoby adriwan_kenoby 7 months ago.

  • Creator
    Topic
  • #30859

    Razva
    Participant

    Hey,

    I know that previously we were required to setup/install Clank manually.

    At this point the Git installation manual specify that we should “Configure the Web Socket server process”. But the Documentation Oro Book doesn’t specify anything about this.

    Can you please let us know what’s the current status on this?

    Cheers,
    Razvan

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #30881
    Dima Soroka
    Dima Soroka
    Oro Core

    Hi Razva

    We do recommend to use Supervisor for web socket setup as it is mentioned in the README, installation chapter in documentation will be updated.

    #30882

    Razva
    Participant

    Thanks for your fast reply, as usual! 🙂

    The “user=www-data” should be the user on which the CRM is running?

    If using a cron, how often should this be executed? Once and left in background?

    #31567

    Razva
    Participant

    For those looking to install Supervisor in CentOS 7, here’s the best tutorial I could find: https://rayed.com/wordpress/?p=1496

    Dima, is it “normal” that the orocrm_message_consumer should not run, only the orocrm_web_socket?

    #31572
    Dima Soroka
    Dima Soroka
    Oro Core

    All OroCRM processes should be owned by web server user (www-data, apache or any other configured in your environment). Using cron for web socket and message queue consumer is not recommended as this processes should be always running and monitored/supervised.

    orocrm_message_consumer should be running, ERROR shows that something is wrong with configuration.

    #31632

    Razva
    Participant

    I think that the config you provided in the README is broken? Here’s my conf:

    ^^^ This is working.

    Now for the message consumer:

    This is NOT working:

    Maybe there’s a syntax error somewhere?

    Thank you! 🙂

    #32587
    Dima Soroka
    Dima Soroka
    Oro Core

    Configuration looks correct, most of the recommendations i found are about reloading configuration:

    #32710
    adriwan_kenoby
    adriwan_kenoby
    Participant

    I have the same problem, even if I reload configuration…

    #32711
    adriwan_kenoby
    adriwan_kenoby
    Participant

    Program name is not display but processes are running and could be visualized by supervisorctl status.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.