ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 5 replies, has 3 voices, and was last updated by Michael Michael 2 years, 3 months ago.

  • Creator
    Topic
  • #12203
    ant-workaholic
    ant-workaholic
    Participant

    When I try to install oro/crm-zendesk extension through UI, I get error: “Ajax Error”, when I try to install it through console, I get this error “oro/crm-zendesk can’t be installed!”. Please, help me with this issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #12220

    Hi,
    To help we need to know more information about your version of OroCRM. Please try with follow instructions http://www.orocrm.com/documentation/index/current/cookbook/how-to-install-extension-from-command-line#using-composer

    Composer will show errors or any incompatibilities

    #12277
    ant-workaholic
    ant-workaholic
    Participant

    I tried to install package through console php app/console oro:package:available –env=prod but I had got this error:
    oro/crm-zendesk can’t be installed!
    And that’s all. I have reinstalled orocrm couple times, last time it was two weeks ago. Please, give me advise, how I can catch this? ๐Ÿ™‚

    P.S. My oro-crm version is 1.7.5 (7b00e38)
    oro-platform is 1.7.5 (dfab0eb)
    Thank you.

    #12280
    Michael
    Michael
    Participant

    Hello, ant-workaholic
    try install using composer with this command
    composer require oro/crm-zendesk:1.4.0 --prefer-dist --update-no-dev
    and after that run

    About this command
    app/console oro:package:available โ€“env=prod
    it only shows list of available extensions
    the installation command should this

    #12310
    ant-workaholic
    ant-workaholic
    Participant

    Hello, again.
    I have tried to install this package following your advises but I got this error:

    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    – Conclusion: remove oro/platform 1.x-dev
    – Installation request for oro/crm-zendesk 1.4.0 -> satisfiable by oro/crm-zendesk[1.4.0].
    – Conclusion: don’t install oro/platform 1.x-dev
    – Conclusion: don’t install oro/platform 1.x-dev
    – oro/crm-zendesk 1.4.0 requires oro/platform 1.7.* -> satisfiable by oro/platform[1.7.x-dev].
    – Can only install one of: oro/platform[1.7.x-dev, 1.x-dev].
    – Can only install one of: oro/platform[1.7.x-dev, 1.x-dev].
    – Installation request for oro/platform 1.x-dev -> satisfiable by oro/platform[1.x-dev].
    `
    When I was trying to ran this command.
    composer require oro/crm-zendesk:1.4.0 --prefer-dist --update-no-dev

    #12436
    Michael
    Michael
    Participant

    Hello
    it seems that you are using dev vesrion of OroCRM so you need to install a dev version of extension
    composer require oro/crm-zendesk:1.x-dev --prefer-dist --update-no-dev

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.