ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 16 replies, has 3 voices, and was last updated by  drivencompassion 3 years, 1 month ago.

  • Creator
    Topic
  • #3193

    drivencompassion
    Participant

    app/console oro:entity-extend:dump –env prod

    Load average on the server is increased to 600+
    load average: 581.99, 169.15, 67.73

    Any suggestions?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Author
    Replies
  • #3194

    drivencompassion
    Participant

    FYI: We have already tried updating the memory in php.ini file. But the script goes on using up the whole memory of the server which would increase the load on the server.

    We have installed all the dependencies. Is there anything that can be updated on the code side or any other option to fix the issue. From the logs, we can see that

    app/console oro:entity-extend:dump –env prod

    is the one which is using up memory. This process is used in the installation of your script.

    #3217
    Dima Soroka
    Dima Soroka
    Oro Core

    hi

    This command is very lite and should not use so much memory and CPU. Can you please give us a bit more details on what was done on your instance in order to have more clear way to reproduce this issue?

    #3223

    drivencompassion
    Participant

    The command ” app/console oro:entity-extend:dump –env prod ” is not some thing which we run. Its is what we see on the top process list when we try to proceed with OROcrm installation.
    And this is the one which using up memory on the server and results in downtime for our other domains.

    We’re on RHEL6 box with 12 GB RAM

    #3228
    Dima Soroka
    Dima Soroka
    Oro Core

    So looks as issue appears during clean installation on RHEL6 box, right? What will be the best way to contact you for additional details as we need to understand better your environment configuration?

    #3229

    drivencompassion
    Participant

    Is there a way to PM you on your or message you my details privately in anyway directly?

    The ORO installed domain generates a lot of php sessions in the system, so you may wish to start there with identifying what is causing so many sessions to open at once.

    This line:

    98 root 20 0 0 0 0 D 66.0 0.0 19:00.85 kswapd0

    Suggests that kswapd0 is taking up the most resources and is constantly going up and down.

    #3231
    Dima Soroka
    Dima Soroka
    Oro Core

    There are no PM function on the forum yet, you can update your profile and I will email you or submit contact us request.

    Thanks

    #3241

    drivencompassion
    Participant

    I’ve update my profile as requested so you can contact me directly.

    #3436

    drivencompassion
    Participant

    Hi Dima, can you check my profile and contact me regarding ORO maxing out 12 GB on memory during the install?

    Even after reloading the OS on the server, restoring all our backups, upgrading PHP to the latest, wiping out our previous ORO install, reinstalling the latest ORO, We are still receiving Out of memory during the installation – which of course affects the performance of everything else on the server.

    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    Fatal error: Out of memory (allocated 183238656) (tried to allocate 72 bytes) in phar:///home/*DOMAIN*/public_html/composer.phar/src/Composer/DependencyResolver/RuleSet.php on line 68
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    We have tried to increase to increase the memory limit via custom php.ini but it is not working. We have also tried all configuration changes mentioned by Roman but the issue is still persisting.

    We have tried with the option ” –with-eaccelerator-doc-comment-inclusion”, Recompile eAccelerator with –with-eaccelerator-doc-comment-inclusion flag, with the same result.

    We have also tried Replace eAccelerator with xCache and APC but server load is still going up and maxing out memory. Can you help further?

    #3437

    Alexandr Smaga
    Participant

    Hi.

    Are you sure that php memory limit is 12 GB?
    As I see from your error message limit is about 170 mb.
    Is it crashed during composer install ?

    #3440

    drivencompassion
    Participant

    My admin ensured the php memory limit is now set to 10 GB of 12 GB on the server. Then tried to install ORO once again but the issue is still persisting. We are getting the same error as mentioned above in the ticket thread:

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    Fatal error: Out of memory (allocated 184025088) (tried to allocate 72 bytes) in phar:///home/*DOMAIN*/public_html/composer.phar/src/Composer/DependencyResolver/Rule.php on line 50
    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Can you please let us know the configuration changes that should be done on the server side so that we can continue with the installation?

    #3441

    Alexandr Smaga
    Participant

    it’s strange, can you give us output of following command

    It could be different limits for web server and for CLI php.

    #3444

    drivencompassion
    Participant

    php -i | grep memory
    >>
    root@************ [/home/************]# php -i | grep memory
    memory_limit => 10240M => 10240M
    Collecting memory statistics => No

    #3447
    Dima Soroka
    Dima Soroka
    Oro Core

    Hi @drivencompassion

    It looks as your issue is happening on composer install or update execution. Also the error itself “Out of memory (allocated 184025088) (tried to allocate 72 bytes)” shows that script is using ~175M and trying to allocate 72 bytes and fail (your config shows that you have memory_limit => 10240M).

    Based on this information i can recommend you following:

    • Run “composer self-update” as there are a lot of discussions and some fixes on memory usage.
    • Try to set memory_limit to “-1” as looks that there are some issues with actual limit and script limit.

    Please let us know if it helps.

    #3452

    drivencompassion
    Participant

    We have changed the memory limit to -1 and receiving the same error.

    Please have a look at the snippet.
    +++++++++++++++++++++++++++++++++++++++++
    root@************** [/home/**************/public_html]# php -r “echo ini_get(‘memory_limit’).PHP_EOL;”
    -1M
    —————
    Fatal error: Out of memory (allocated 183238656) (tried to allocate 32 bytes) in phar:///home/**************/public_html/composer.phar/src/Composer/DependencyResolver/Rule.php on line 62
    +++++++++++++++++++++++++++++++++++++++++

    The command ” self-update ” dose not seems to be working.

    Please let us know how to proceed further.

    #3565

    Alexandr Smaga
    Participant

    Hi,

    Why you set it to -1M ? Could you please try with -1 ?

Viewing 15 replies - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.