ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 10 replies, has 2 voices, and was last updated by  mousebat 3 years, 5 months ago.

  • Creator
    Topic
  • #3220

    mousebat
    Participant

    I’ve had to install via cli app/console oro:install because when I try to install through a web browser with the install.php it redirects me nowhere after I click the next step (all prerequisites are met).

    I’m redirected to myroot/web/installer which is a blank page.

    The CLI has built the database schema – but now what? where can I find the login page?

    Thanks

    MB

Viewing 10 replies - 1 through 10 (of 10 total)
  • Author
    Replies
  • #3227

    Alexandr Smaga
    Participant

    Hi.

    Seems that you have some issues in virtual host configuration.
    Login page should be available under http://yourhost.name/ URL. (or http://yourhost.name/app_dev.php for developer mode).

    Keep in mind that directory index in symfony 2 is app.php instead index.php

    #3259

    mousebat
    Participant

    Thanks asmaga – I have this in my vhost file:

    If I point my browser to myhost/web/app_dev.php if advises me “You are not allowed to access this file. Check app_dev.php for more information.”

    If I use just myhost/web/ I get a blank page.

    I turned on display_errors in my php.ini and now I get this:

    Fatal error: Uncaught exception ‘RuntimeException’ with message ‘The php executable could not be found, add it to your PATH environment variable and try again’

    php -v seems to give proper output? So does which php (/usr/bin/php)…

    I tried “export PHP_PATH=/usr/bin/php” but still get the fatal error of php could not be found?

    Looks like the function PhpExecutableFinder is being called and it’s not finding anything?

    I’m at a loss now – we’re in the process of choosing a crm and I thought orocrm looked nice and malleable…

    Hope someone can help – is there anything else I can do to debug this? I followed the steps in the install README to the absolute letter but I’ve never used composer and symfony so I may have not done something that to a user of this software would be elementary…

    MB

    #3263

    Alexandr Smaga
    Participant

    Hello.

    It’s very strange error. Can you give us more information ? What’s OS do you use ? What’s version of PHP?

    If I point my browser to myhost/web/app_dev.php if advises me “You are not allowed to access this file. Check app_dev.php for more information.”

    It’s OK, due to access to dev environment is allowed only in case if application deployed on localhost. You can disable this check just commented few lines in app_dev.php

    #3267

    mousebat
    Participant

    Ok so I went back to the beginning and uncomplicated a few things:

    I have attempted this on a clean install of Ubuntu 13.10 running apache 2.4.6 with PHP 5.5.3 running in a vmware virtual machine:

    The crm-application folder is expanded into the /var/www/ normal web root and the default vhost (000-default.conf) is this:

    When I navigate the web browser to http://myfqdomain/install.php I get the installer’s system requirements check that tells me all prerequisites are correct and installed. Then on clicking the “Next” Button at the bottom of the browser window it redirects me to the directory http://myfqdomain/installer which flat out does not exist – The apache2 error.log shows:

    I’ve followed everything in the README to the letter and now I’m stuck? It’s like there are files missing somewhere – How does anyone get this installed? Is there some witchcraft I’m missing here?

    Anyone here care to try it – download Ubuntu server – install nodejs and all the prerequisite php modules and run through the composer install. It doesn’t work!!

    I’ve no idea what else I can do, my htaccess file in the /var/www/web folder looks like this:

    Please, someone help me with this!

    Kind Regards

    MB

    #3268

    mousebat
    Participant

    Directory in /var/www/

    Directory in /var/www/web/

    Directory in /var/www/app/

    There is no installer directory! except in:

    #3269

    mousebat
    Participant

    I’ve now tried the CLI installation with:

    It borks because the 256mb of memory I set as the memory_limit in the cli and apache2 php.ini file is not enough by a few megabytes.

    So I upped the memory_limit’s on both php.ini files to use 512mb and restarted and it now comes back with this error:

    and

    When I check line 42 in WebSocket.php it looks like the __construct function seems to be still using port 8080 despite me specifically asking it to use port 80 in the composer install (parameters.yml shows as 80!).

    Now that I’ve overridden this in the __construct function the command line install completes.

    So if I now browse to http://myfqdomain it just shows me the ftp view of the /var/www/web folder. I click on app.php and it does nothing. If I click the app_dev.php it just says:

    the check.php file outputs:

    #3270

    mousebat
    Participant

    Right – I’ve edited the web/app.php file and edited this line:

    To…
    $kernel = new AppKernel('prod', true);

    Now I can browse to myfqdomain and it takes me to the login!

    Will someone please update the README with an example of apache2 vhost file and a .htaccess example. Also explain how to enable or disable the development environment, its going to help people install and actually start using this software. I know this is just an RC but the lack of concise install documentation = fail to me.

    MB

    #3272

    mousebat
    Participant

    I’ve logged in and there is a message in red:

    #3273

    Alexandr Smaga
    Participant

    Hello.

    First of all try to check that mod_rewrite is installed.

    When I check line 42 in WebSocket.php it looks like the __construct function seems to be still using port 8080 despite me specifically asking it to use port 80 in the composer install (parameters.yml shows as 80!).

    Why do you sync so? I see code that creates object of WebSocket class and it pass parameters from parameters.yml. Check TopicPublisher::getWs method.
    Why did you set websocket port to 80? This port is occupied by webserver by default(apach in your case)

    You are not allowed to access this file. Check app_dev.php for more information.

    As I said before this is correct behavior for applications based on symfony2. To access dev environment from any host you should comment

    those lines.

    Hope this will help.

    #3274

    mousebat
    Participant

    Everything is working now but I’m still left with this error message “Synchronizer can’t connect to server, try reconnect” whenever a user logs in. What is “Synchronizer” and why can’t it connect to the server?

    Why do you sync so?

    Not sure I understand what you mean? I don’t know what syncing is in the world of orocrm?

    Why did you set websocket port to 80? This port is occupied by webserver by default(apach in your case)

    What is the websocket port used for? I assumed that was just the port that apache was using for orocrm – hence I set it to port 80… Is it to do with the API?

    Is there a book (or even documentation) in the pipeline? I know it’s early days but I really like the interface and think you’re on to a winner.

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.