Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 5 replies, has 2 voices, and was last updated by Mike Kudelya Mike Kudelya 6 months, 1 week ago.

  • Creator
    Topic
  • #34483

    anderpydev
    Participant

    I am using OroCRM Application version 2.0.8

    I configured the server as per recommendations (NGINX, MariaDB, PHP7.0, Memcached). Server operating system: CentOS 7 (64). I installed the application (composer).

    Server is production. The application works correctly for reminders (email and flash) and sending messages. I have configured the basic settings. I adapted the translation to my needs.

    I added Cron:

    This is my file “parameters.yml”:

    and Message Queue consumer process in Supervisor:
    /etc/supervisord.d/user.conf

    Everything is ok. But. I do not import data. I tried importing leads.
    This is my import report:

    The imported file is a template from OroCRM “Download Data Template”.

    Did anyone have a similar problem?
    I ask you for help, it is very important and urgent for me.

    PS:PS: I cleaned the cache, restarted the service and the entire server. Nothing helps. I have not found a solution anywhere.

    Recent log entries: https://pastebin.com/4gkNzYTM

    Regards,
    Matthew

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #34486
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi

    “General error: 2006 MySQL server has gone away” is common problem of mysql 5.7. Try to increase max_allowed_packet option. Here is my mysql config file:

    #34487

    anderpydev
    Participant

    Thank you Mike for your response.

    I changed settings in the database. My file looks like this:

    I reset the mysql server and re-imported.
    I still have the same error.

    Jobs List in OroCRM:

    Log (prod.log)

    Am I doing something wrong? I kept on every step of the documentation. The only changes I made in translation and overwriting entities (description in documentation).
    app / Resources / OroSalesBundle / views / Lead / update.html.twig

    #34488

    anderpydev
    Participant

    I increased max_allowed_packet = 204857600

    I also noticed that there is no mass deletion of records. As I am going to highlight four records and press delete, it does not delete the records. I can only remove it individually.

    #34491

    anderpydev
    Participant

    It works for adding contacts. There is still the same error when importing leads and opportunities.

    Edit:

    Exact application behavior:
    When I import contacts and select the strategy “Add or Replace” – error appears: error in part # 1: Access denied to entity “Oro \ Bundle \ ContactBundle \ Entity \ Contact”

    When I import contacts and select the “Add” strategy – import works.

    I have no choice in strategy when importing leads and opportunities. Therefore, the application imports data by default using the “Add or Replace” strategy.

    Then import does not work.

    #34497
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi

    First of all I think that you should resolve your problem with mysql’s ‘Gone Away’. Try to install version 5.5.

    Access denied to entity “Oro\Bundle\SalesBundle\Entity\Lead”

    The current user doesn’t have ‘create’ or ‘edit’ permissions to the Lead entity. Please set correct permissions there: System -> User Management -> Roles -> [Role] -> Edit.

    I added Cron:

    app/console oro:install –env=prod

    I would like to know, why do you add the install command to cron ?

    Also please add the following code to this line and try to run the import again. Will appear the exception in log file ?

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

ssossossosso