ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 14 replies, has 3 voices, and was last updated by Anton Anton 11 months, 4 weeks ago.

  • Creator
    Topic
  • #23846
    Anton
    Anton
    Participant

    Hello, I’m trying to use the package manager but when I click it, it throws:

    404 Not Found

    The page you requested could not be found. Please make sure the path you used is correct.

    Is it a permissions issue?

    Do you have any idea why package manager in OROcrm is giving a 404 error?

    Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • Author
    Replies
  • #24143
    Anton
    Anton
    Participant

    Also, is it possible to edit these posts? As I want to remove the URL

    #24166
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi

    Which version of oro are you using ? Do you use brand new installation, without any modifications?
    I suggest you change web document root from root project directory to /web.

    #24168
    Anton
    Anton
    Participant

    Versions:

    Oro Packages
    Package Name Version License
    oro/moment-timezone 0.3.1 MIT
    oro/jsplumb 1.7.6 MIT GPL-2.0
    oro/doctrine-extensions 1.0.12 MIT
    oro/platform 1.10.6 MIT
    oro/crm-task-bundle 1.0.3 OSL-3.0
    oro/crm-call-bundle 1.0.2 OSL-3.0
    oro/crm 1.10.6 OSL-3.0

    It is a brand new installation with Magento plugin. Package manager never loaded even before Magento installation.

    Can you explain what you mean by changing the web document root?

    #24184
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi

    Your url starting with web/install.php/login, instead install.php/login, because i suppose that you set your DocumentRoot to root project directory. You should use following url (just add web directory to it):

    Maybe these step will help you:

    – Log files (app/logs/prod.log, app/logs/dev.log) can help you understand what is wrong.
    – Put this line (and change path to php interpreter) to your VirtualHost section of apache (if you really is using it)

    #24187
    Anton
    Anton
    Participant

    I’m using nginx rather than apache.

    When you say “just add web directory” do you mean appending my domain name to the beginning?

    Are you suggesting that my DocumentRoot is wrong, and that is why the package manager is not loading?

    #24201
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi

    For example your oro project located here /www/sites/oro, would be right set DocumentRoot to /www/sites/oro/web. It is just right way to use oro. I think error what happened you may see at your log files.

    #24241

    emateu
    Participant

    Hi

    I’m having the same issue. I’m running 1.10 with nginx and the server root seems to be fine: /var/www/crm-application/web;

    Its my first time installing OroCRM so issue is expected to be on my side…. I’m not sure where I’m wrong.

    #24242

    emateu
    Participant

    Ok I solved this by using this nginx configuration (https://www.orocrm.com/documentation/index/current/book/installation). Sorry!

    #24243
    Anton
    Anton
    Participant

    Hi emateu,

    Are you talking about the nginx virtual host configuration?

    Is this all you changed?

    #24244
    Anton
    Anton
    Participant

    @Mike – Just for reference, there are no log entries generated in my case

    #24461
    Anton
    Anton
    Participant

    We have gotten package manager to load. However extensions are not installing (perpetual loading .gif) Will attempt to install through Composer instead.

    #24467
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi

    When ‘loading’ doesn’t disappear it means that somewhere an error has occurred. Try to look at app/logs/prod.log, app/logs/dev.log or on js errors or probably ajax response error. Make sure that you have access permissions on /vendor directory from UI.

    #24468
    Anton
    Anton
    Participant

    Thanks Mike.

    We were able to get it to work by installing via console. It was a memory limit error.

    To fix we use:

    php -d memory_limit=-1 app/console oro:install –force –drop-database

    Where memory limit is set to -1.

    It has installed. I have set up the integration, and scheduled a sync via this guide: https://www.orocrm.com/blog/news/orocrm-zendesk-integration

    However, no customer data is appearing yet, and the document does not say clearly where it will appear.

    We are almost good-to-go, but not quite yet. I will keep updating this thread for anyone else having troubles.

    #24473
    Anton
    Anton
    Participant

    Ok, we are all good.

    Zendesk imports appear under contacts.

    If integration is not working, open the integration, click edit, and at the bottom are logs. Our problem was authentication as indicated by the log, and after it fixed everything imported in a minute or two.

    Resolved

Viewing 14 replies - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.