ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 3 replies, has 3 voices, and was last updated by  isaac.sampaio 4 years, 2 months ago.

  • Creator
    Topic
  • #391

    Brodie
    Participant

    I have OpenSSL version 1.0.1e. When I run:
    php composer.phar install --verbose

    I receive the error:

    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    – ass/xmlsecurity dev-master requires lib-openssl >=0.9.0 -> the requested linked library openssl has the wrong version installed or is missing from your system, make sure to have the extension providing it.
    – oro/platform dev-master requires ass/xmlsecurity dev-master -> satisfiable by ass/xmlsecurity[dev-master].
    – Installation request for oro/platform dev-master -> satisfiable by oro/platform[dev-master].

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #408
    ishakuta
    ishakuta
    Participant

    Hi
    Did you install libssl from mac ports?
    Can you provide output for locate libssl

    #423

    Brodie
    Participant

    Ah ha, I’ve got it. That port doesn’t exist, there is openssl (which was installed already) and openssl97. I’ve done the following:

      sudo port install openssl97 php5-openssl icu php5-intl
    #572

    isaac.sampaio
    Participant

    Hello,

    I’m also having this problem. I use windows and when I type openssl version returns the following: Openssl 0.9.8e 23 Feb 2007.

    Does anyone know how can I solve this problem?

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.