ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 1 reply, has 1 voice, and was last updated by  curata 1 year, 9 months ago.

  • Creator
    Topic
  • #16245

    curata
    Participant

    Hi there,
    I installed a clean version of OroCRM 1.8.2 using method 1 of the page below. The install is working nicely.
    http://www.orocrm.com/documentation/index/current/book/installation#book-installation-command

    I’m now trying to integrate with the Mailchimp extensions as found in the marketplace using the following command and as per instructions for using composer as found on this page http://www.orocrm.com/documentation/index/current/cookbook/how-to-install-extension-from-command-line.

    composer require oro/crm-mail-chimp:1.0.0 –prefer-dist –update-no-dev

    I’m receiving the below output which seems to indicate Mailchimp extension is not compatible with oro/platform 1.8.2???? Do I need to modify something in composer.json? Quite confusing, I would have thought this would work quite easily. Any help is appreciated.

    root@web01-acm-magento-oro:/var/www/html/agedcare_crm/agedcare182/crm-application# composer require oro/crm-mail-chimp:1.0.0 –prefer-dist –update-no-dev
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies
    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    – Conclusion: remove oro/platform 1.8.2
    – Installation request for oro/crm-mail-chimp 1.0.0 -> satisfiable by oro/crm-mail-chimp[1.0.0].
    – Conclusion: don’t install oro/platform 1.8.2
    – Conclusion: don’t install oro/platform 1.8.2
    – oro/crm-mail-chimp 1.0.0 requires oro/crm 1.4.* -> satisfiable by oro/crm[1.4.x-dev].
    – oro/crm 1.4.x-dev requires oro/platform 1.4.* -> satisfiable by oro/platform[1.4.x-dev].
    – oro/crm 1.4.x-dev requires oro/platform 1.4.* -> satisfiable by oro/platform[1.4.x-dev].
    – Can only install one of: oro/platform[1.4.x-dev, 1.8.2].
    – Can only install one of: oro/platform[1.4.x-dev, 1.8.2].
    – Installation request for oro/platform == 1.8.2.0 -> satisfiable by oro/platform[1.8.2].

    Installation failed, reverting ./composer.json to its original content.

Viewing 1 replies (of 1 total)
  • Author
    Replies
  • #16249

    curata
    Participant

    Resolved. Updated version of mailchimp extensions to 1.4.3 but only found this by looking at composer.json after trying to run the install. Marketplace only shows 1.0.0.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.