ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 7 replies, has 2 voices, and was last updated by  Roman Grebenchuk 2 years, 1 month ago.

  • Creator
    Topic
  • #12975

    Soopadoubled
    Participant

    Hi,

    I’m having issues installing v1.8.0. I’ve cloned the 1.8.0 branch, ran $ composer install, and proceeded to install Oro CRM with $ php app/console oro:install (with database setup and db details in app/config/parameters.yml

    Everything runs okay initially, my environment passes all initial tests.

    Installation gets stuck after the bundle OroCRM\Bundle\SalesBundle\Migrations\Schema\OroCRMSalesBundleInstaller and throws the following error:

    Neither Oro’s logs or my servers PHP logs contain anything relating to the installation.

    Any insight would be greatly appreciated!

    Cheers,

    Ian

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #12976

    Hi,
    Could you disable OpCache in php.ini, recreate DB, remove app/cache/dev and try again installation?

    #12981

    Soopadoubled
    Participant

    Thanks Roman,

    I tried that by adding ini_set('opcache.enable', 0); to app/console.php, recreated DB and cleared cache.

    This is confirmed when the installer runs:

    | OK | intl ICU version should be at least 4+
    | WARNING | Install and enable a PHP accelerator like APC (highly recommended).

    However I still get the same error.

    Thanks,

    Ian

    #13222

    Soopadoubled
    Participant

    Just a quick update.

    I tried installing via the Web GUI – installation failed and logs indicated the same issue.

    I then tried just installing Oro BAP on its own, which installs and runs fine.

    #13258

    Soopadoubled
    Participant

    I’ve successfully installed OroPlatform v1.8 and Oro CRM v1.7.

    Either upgrading v1.7 to v1.8 or adding CRM to OroPlatform v1.8 results in the same issue.

    #13259

    What is your default locale and ICU version?

    #13264

    Soopadoubled
    Participant

    Hi Roman – how would I identify those?

    I’ve now managed to install v1.8 by installing Oro CRM v1.7, then upgrading using the following procedure:

    $ git clone https://github.com/orocrm/crm-application.git .
    $ git checkout 1.7
    $ composer install --prefer-dist
    $ php app/console oro:install

    I then verified everything was running and upgraded:

    $ git checkout 1.8
    $ composer install --prefer-dist
    $ rm -rf app/cache/* web/js/* web/css/*
    $ php app/console oro:platform:update --env=prod --force

    This threw an error when trying to log in so I ran:

    $ php app/console cache:c -e prod --no-warmup

    I can now log in and identify I’m running v1.8:

    I’d be happy to continue assisting to try and locate the root of the issue with a clean v1.8 install if that helps?

    #13288

    Could you share php error log with errors raised during app/console oro:platform:update? Actually it can be timeout error or error with concurrent access to caches files

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.