ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 11 replies, has 4 voices, and was last updated by  bojan050 1 year, 3 months ago.

  • Creator
    Topic
  • #20049

    bojan050
    Participant

    Hi,

    I’m trying to install OroCRM with this guide: https://www.orocrm.com/documentation/index/current/book/installation

    I have set my php memory limit to 2G. When I execute composer install –prefer-dist –no-dev, after a while I get an out of memory error. Is it normal that this process takes up more than 2 gigs of memory?

    Any idea how to proceed?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Author
    Replies
  • #20053

    Abdessamad
    Participant

    Hi Bojan050,

    Maybe try to download OroCRM with vendor directory, go to https://www.orocrm.com/download and download OroCRM as ZIP

    #20059

    bojan050
    Participant

    Hi, thanks for the suggestion. I tried that too yesterday. Now my install is failing at the step: Clear cache before database initialization. It fails.

    The log says [Symfony\Component\HttpFoundation\File\Exception\FileNotFoundException]
    The file “The PHP executable could not be found.” does not exist

    I am on CENTOS. WHM / Cpanel is running on it too.

    Any ideas?

    #20060
    Ivan Klymenko
    Ivan Klymenko
    Oro Core

    Hi bojan050,
    regarding the issue with memory limit, could you please check is the composer.lock in place after the clone?

    #20061

    bojan050
    Participant

    Hi Ivan,

    Yes the .lock file is in place.

    #20067

    bojan050
    Participant

    Okay, with lots of workaround I got OroCRM installed (I used app/console oro:install –env prod –drop-database –force).

    Now when I navigate I get this error in the Chrome-console en the page keeps loading until I manually refresh the page:

    Uncaught Error: The route “_wdt” does not exist.

    Something to do with the WebProfilerBundle?

    #20076
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi,

    Do you have enabled xdebug when you run composer install? Anyway please follow these steps to repair your composer. Regarding to the issue with “Uncaught Error: The route “_wdt” does not exist”, do you have these lines in app/config/routing_dev.yml file?

    #20077

    bojan050
    Participant

    No, I don’t have Xdebug running. I have tried a memory_limit of 3GB and -1 in php.ini. Both to no avail.

    Also, I had to change this in app.php:

    to

    otherwise I get an php executable not found error.

    I guess that’s the problem.

    #20078
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Did you run for example http://orocrm-application.local/ and got 404 ?

    #20079

    bojan050
    Participant

    When I set prod to false I get this:

    Fatal error: Uncaught exception ‘Symfony\Component\HttpFoundation\File\Exception\FileNotFoundException’ with message ‘The file “The PHP executable could not be found.” does not exist’ in /home/oerweb/public_html/oro/vendor/oro/platform/src/Oro/Bundle/InstallerBundle/CommandExecutor.php:322 Stack trace: #0 /home/oerweb/public_html/oro/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/OroEntityExtendBundle.php(172): Oro\Bundle\InstallerBundle\CommandExecutor::getPhpExecutable() #1 /home/oerweb/public_html/oro/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/OroEntityExtendBundle.php(97): Oro\Bundle\EntityExtendBundle\OroEntityExtendBundle->getPhpExecutable() #2 /home/oerweb/public_html/oro/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/OroEntityExtendBundle.php(84): Oro\Bundle\EntityExtendBundle\OroEntityExtendBundle->checkConfigs() #3 /home/oerweb/public_html/oro/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/OroEntityExtendBundle.php(62): Oro\Bundle\EntityExtendBundle\OroEntityExtendBundle->ensureIn in /home/oerweb/public_html/oro/vendor/oro/platform/src/Oro/Bundle/InstallerBundle/CommandExecutor.php on line 322

    #20080
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Here is my virtual host for apache, please set right path to PHP executable file in ORO_PHP_PATH:

    #20081

    bojan050
    Participant

    Ha, I added the right ORO_PHP_PATH en set $kernel = new AppKernel(‘prod’, false); It’s seems to be working now!

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.