ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 7 replies, has 2 voices, and was last updated by  Alexandr Smaga 3 years, 2 months ago.

  • Creator
    Topic
  • #3656

    Anis
    Participant

    Hi dear tech team and community members

    I found the informations regarding orocrm very interesting.
    And so far I wish to get it working, but till now I just found installation guides for local installations and something using “composer”
    Can somebody please explain to a dummie how to get orocrm running on a Magento Dedicated linux server with cpanel?

    Even paying for the installation is an option. Let me know whom and how much.
    (If this is the ordinary way to get it running for an ordinary joe.)

    Kind regards
    Anis

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #3657

    Anis
    Participant

    to be more concret I wish to get it running on a shared Magento hosting

    #3658

    Alexandr Smaga
    Participant

    Hello.

    Unfortunately I’m not familar with cPanel, but regular installation requires following steps:

      Register domain
      Connect new domain to your server (usually it’s configuration of webserver nginx/apache
      Create DB and DB user with correct permissions
      Unpack OroCRM to webroot(should be configured at step 2)download zip archive or clone repo(if you familar with GIT)
      Run installer http://yourdomain.example/install.php

    Hope this will help you.

    #3661

    Anis
    Participant

    🙂 I thank you for the fast and helpful respond

    Following your describtion I receive the following error message
    as soon as I enter the url to the install.php

    Parse error: syntax error, unexpected ‘[‘, expecting ‘)’ in /home/ … /app/OroRequirements.php on line 26

    This line is:
    $nodeExists->setEnv([‘PATH’ => $_SERVER[‘PATH’]]);

    Kind regards
    Anis

    #3663

    Alexandr Smaga
    Participant

    OroCRM requires php version greater then 5.4.4 it seems that you have less version

    #3666

    Anis
    Participant

    That was a good point.
    The PHP version is 5.3.27

    I reached out for the support team from my hoster and send them the oro requirements

    Could you check if the following states show an additional point to upgrade?

    cPanel Version 11.42.0 (build 23)
    Theme x3
    Apache version 2.2.25
    PHP version 5.3.27
    MySQL version 5.5.36-cll
    Architecture x86_64
    Operating system linux
    Perl version 5.10.1
    Kernel version 2.6.32-279.14.1.el6.x86_64
    cPanel Pro 1.0 (RC1)

    #3670

    Alexandr Smaga
    Participant

    Hi.

    From my point only php should be upgraded, also please check php extensions and nodejs(needed for JS performance improvement)

    #3671

    Alexandr Smaga
    Participant

    Here is a full list for you.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.