ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 5 replies, has 3 voices, and was last updated by  Jose Luis Fonseca 1 year, 7 months ago.

  • Creator
    Topic
  • #8212

    manelpm10
    Participant

    I’ve successfully installed OroCRM in a vagrant machine via GitHub + composer and using command line installation following the steps in the installation documentation (https://github.com/orocrm/crm-application).

    After finish the installation, I’ve entered into /user/login URL and used the login/password provided in the installation, but, I can’t enter in the application. I’m redirected to login URL every time I try enter on OroCRM without show any error.

    Any ideas?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #8214

    manelpm10
    Participant

    Installation log:

    And no erros in apache2/error.log

    #8215
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Hello, manelpm10.

    Installation log looks completely fine. Please, try to reset your password using following command:php app/console oro:user:update admin --user-password=123456 --env=prod – it will set password of user admin to 123456. After that, please, try to login by user admin with new password 123456.

    Another problem might be in incorrectly working redirects for your host. So, instead of sending your data to login url /user/login-check it redirects you back to /user/login. To check that you can disable all modules that can do redirects or rewrites (alias, rewrite, vhost_alias etc), remove cache (rm -rf app/cache/*) and then go to http://host/app.php/ and try to login again. If you’ll see error “Invalid user name or password.” then login attempt was performed, othewise you should check whether http requests sent to an application.

    #8217

    manelpm10
    Participant

    Thank you very much for your answer, Yevhen!

    I’ve changed the pass as you suggested but still does not work, anyway, doing some tests I’ve tried to mark the checkbox “Remember me on this computer” an then I can login.

    I know, doesn’t have any sense, but I only can login into OroCRM if I check these option.

    #8223
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Please, check your session path (default is app/cache/sessions) – it should be writable.

    #13343

    Jose Luis Fonseca
    Participant

    Hey there! i am having the same issue, it seems to redirect back to login. however if i go to reset password it does not redirect. here is my nginx config


    server {
    listen 80;
    listen 443 ssl;
    server_name mysql.dev;
    root "/home/vagrant/Code/Mysql/web";

    index index.html index.htm index.php app.php;

    charset utf-8;

    location / {
    try_files $uri $uri/ /app.php?$query_string;
    }

    location = /favicon.ico { access_log off; log_not_found off; }
    location = /robots.txt { access_log off; log_not_found off; }

    access_log off;
    error_log /var/log/nginx/mysql.dev-ssl-error.log error;

    sendfile off;

    client_max_body_size 100m;

    # DEV
    location ~ ^/(app_dev|config)\.php(/|$) {
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_pass unix:/var/run/php5-fpm.sock;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_intercept_errors off;
    fastcgi_buffer_size 16k;
    fastcgi_buffers 4 16k;
    }

    # PROD
    location ~ ^/app\.php(/|$) {
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_pass unix:/var/run/php5-fpm.sock;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_intercept_errors off;
    fastcgi_buffer_size 16k;
    fastcgi_buffers 4 16k;
    # Prevents URIs that include the front controller. This will 404:
    # http://domain.tld/app.php/some-path
    # Remove the internal directive to allow URIs like this
    #internal;
    }

    location ~ /\.ht {
    deny all;
    }

    ssl_certificate /etc/nginx/ssl/mysql.dev.crt;
    ssl_certificate_key /etc/nginx/ssl/mysql.dev.key;
    }

    I am using Homestead as a VM.

    Thanks in advance.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.