ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 4 replies, has 2 voices, and was last updated by  hmadhur 1 year ago.

  • Creator
    Topic
  • #22085

    hmadhur
    Participant

    Hi,

    I am having more than one instance of OroCRM in the same server.

    What happens is that when I am working on one instance, the other instance fails to load. I get an empty response error when I load the other instance. When I restart apache server then the other instance loads. But then the first instance fails to load.

    Can anybody please help me understand why this happens? I need to have more than one instance running for different languages on the same machine. Is there a restriction that only one instance can run on one server?

    Please let me know.

    Thanks and Regards,
    Madhur

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #22086

    hmadhur
    Participant

    This is the error I get. And when I restart the apache service by running service httpd restart the instance loads, but the other instances give the same error.

    #22194
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi,

    As i understood you have different web roots and databases?
    If yes, i think it is server configuration troubles. For example how i have configured many virtual hosts with absolutely different db and web root:

    #22202

    hmadhur
    Participant

    Hi Mike,

    Thanks for the response.

    That is exactly how I have configured my virtual hosts. The problem was with opcache.ini. Since the settings given in the documentation was for one instance of OroCRM on the server I went ahead and doubled the values for the following settings:

    Existing Settings:
    opcache.memory_consumption=256
    opcache.interned_strings_buffer=8
    opcache.max_accelerated_files=11000

    Updated Settings:
    opcache.memory_consumption=512
    opcache.interned_strings_buffer=16
    opcache.max_accelerated_files=22000

    Also in php.ini I changed the value of Output buffering from 4096 to 8192.

    These changes resolved my problem.

    Thanks and Regards,
    Madhur

    #22203

    hmadhur
    Participant

    Hi Mike,

    I have another pressing issue. I have noted that in another question. Can you please help me with that as well?

    Merge codes in URL links for Email Templates

    Thank and Regards,
    Madhur

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.