ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 1 reply, has 2 voices, and was last updated by Mike Kudelya Mike Kudelya 10 months ago.

  • Creator
    Topic
  • #29975

    bosumflici
    Participant

    Hi,

    I have this code in a controller:

    and this is the equivalent sql command from the debug log:

    The problem is that they are not returning the same result. For the above values the querybuilder return only 2 records, and the normal sql select command return 6 records. Of course the second one is the correct one!!!

    I cannot figure out why querybuilder returns different result for any values than the normal sql command.

    If someone can help i appreciate!
    PS: i tried getArrayResult() with no effect.

Viewing 1 replies (of 1 total)
  • Author
    Replies
  • #30399
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi

    I can’t test you case, but try to understood on which step results will be the same when you start remove join and where. Are you sure that this sql is final and any acl restrictions don’t applied? Usually i get sql with getSQL function $qb->getQuery()->getSQL();

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.