ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 5 replies, has 4 voices, and was last updated by vodvud vodvud 1 month, 2 weeks ago.

  • Creator
    Topic
  • #11235

    jonbill
    Participant

    I’m trying to get email sync working but the job fails on every run with no great error log :

    [Exception]
    The email synchronization failed for the following origins: 2.

    Query: “”””.
    Found 13444 email(s).
    Processed 500 of 13444 emails.
    Processed 1000 of 13444 emails.
    Processed 1500 of 13444 emails.
    Processed 2000 of 13444 emails.
    Processed 2500 of 13444 emails.
    The synchronization failed. Error: Line “:
    “does not match header format!.
    The synchronization failed. Error: Line “:
    “does not match header format!.
    Finding an email origin …
    Found “j@domainname.co.uk (imap.gmail.com)” email origin. Id: 2.
    Exit because all origins have been synchronised.

    From what I understand the scripting is saying everything has been sync’d however no emails are appearing in the email chain on Oro? The overall status of the task is also “failed”

    Can anyone help?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #11276

    Hello, @jonbill

    Seems like this issue is connected with bug at Zend library http://framework.zend.com/issues/browse/ZF2-581.
    It will definitely be investigated by us in the nearest future.

    If you need a quick fix to make it work you may go to Oro\Bundle\ImapBundle\Mail\Storage and wrap the next line in ‘getMessages’ method into try..catch block:

    Then go to Oro\Bundle\ImapBundle\Sync\ImapEmailSynchronizationProcessor::syncEmails method and put the next code in the beginning of ‘foreach’ cycle:

    Best regards,
    Andrey

    P.S. What version of Oro do you use? This may help us to solve the problem more quickly.

    #11284

    jonbill
    Participant

    thanks for the input. i’m running 1.7.1

    however, the paths you’ve explained above don’t seem to exsist?

    #12453

    brunpatoch
    Participant

    Hello,
    did you find a solution?

    #35083
    vodvud
    vodvud
    Participant

    Hi all!
    I had same problem and I applied solution from this topic.

    After that was a problem with disable folders.

    See: https://github.com/orocrm/platform/blob/24234ab559c3bd820d4f8a3d13f92534d6fdfc33/src/Oro/Bundle/ImapBundle/Sync/ImapEmailSynchronizationProcessor.php#L113-L116

    For myself I changed it like:

    Now is not disable, it is good.
    But still skipping if folder has unsupported email format.

    I need solution for a quick fix, how skip only one email but don’t skip all folder?
    It will be enough for this stage.

    Thank you!

    • This reply was modified 2 months, 1 week ago by vodvud vodvud.
    • This reply was modified 2 months, 1 week ago by vodvud vodvud.
    #35290
    vodvud
    vodvud
    Participant

    Hi!
    Can anyone help?

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.