ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 6 replies, has 3 voices, and was last updated by  zhex900 2 years, 4 months ago.

  • Creator
    Topic
  • #7402

    zhex900
    Participant

    Hi,

    I have installed OroPlatform in a docker container. But when I go to the webpage, it gives a blank page. Php is working. What should I do?

    this is from nginx in sites-enabled.

    server {
    listen 80;
    server_name localhost;
    root /var/www/orocrm/platform-application/web;

    index app.php;
    access_log /var/log/nginx/$host.access_log;
    error_log /var/log/nginx/dev.error_log info;
    try_files $uri $uri/ @rewrite;

    location @rewrite {
    rewrite ^/(.*)$ /app.php/$1;
    }

    location ~ [^/]\.php(/|$) {
    fastcgi_split_path_info ^(.+?\.php)(/.*)$;

    if (!-f $document_root$fastcgi_script_name) {
    return 404;
    }

    fastcgi_index app.php;
    fastcgi_read_timeout 10m;
    fastcgi_pass unix:/var/run/php5-fpm.sock;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include fastcgi_params;
    }
    }

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #7403

    zhex900
    Participant

    I think my file permission is not right.

    But I already done
    chown -R www-data:www-data /var/www/orocrm
    chmod -R 777 app/cache

    #7404

    zhex900
    Participant

    This is a the head of my /var/log/nginx/platform_application_error.log

    #7410
    ignat
    ignat
    Oro Core

    Hi,

    Did you already installed application in the command line (oro:install command) or you want to install it in the web? Anyway you can try to prepare caches from the command line:

    Does this command produces any errors?

    Thanks,
    Ignat

    #7421

    zhex900
    Participant

    Hi,

    I used command line install.

    Tried your suggested command. It runs with no errors. But I still get a blank page.

    I think it is a problem with file permissions. But I cannot enable acl on my machine. Also chmod +a is invalid command too.

    Any ideas?

    Jake He

    #7423

    Rodolfo
    Participant

    What is your Docker’s operational system?

    Ubuntu:
    sudo apt-get install acl

    CentOS:
    sudo usermod -a -G www-data your_user
    groups your_user
    sudo chgrp -hR /var/www/html www-data

    #7424

    zhex900
    Participant

    I solve the write permission problem. This is what I did.

    Use Device Mapper (LVM) for docker’s storage not the default AUFS
    http://stackoverflow.com/questions/22714885/how-to-use-setfacl-within-a-docker-container

    Reload the docker image I built for orocrm

    Run these to set the permissions.
    setfacl -R -m u:www-data:rwX -m u:`whoami`:rwX app/cache app/logs
    setfacl -dR -m u:www-data:rwx -m u:`whoami`:rwx app/cache app/logs

    For your information this is my machine OS.
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID: LinuxMint
    Description: LMDE MATE Edition
    Release: 1
    Codename: debian

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.