ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 30 replies, has 2 voices, and was last updated by munszu munszu 1 year, 7 months ago.

  • Creator
    Topic
  • #17439
    munszu
    munszu
    Participant

    Hi,

    I’m not sure whether you offer support for third-party solutions but here goes.
    I tried installing Orocrm on my own but I kept running into errors with Composer, I don’t have much experience using it.
    So I thought I give a try to the Bitnami image as it seemed simple enough, but I’m unable to install any packages on their solution. I get the following error:
    http://pastebin.com/kDhmueER
    I tried increasing the memory inside php.ini and the other settings file bitnami used to no avail. I also tried setting the cache folder to 777, but I only ended up getting an 503 error whenever I tried accessing the dashboard.
    Any help would be most appreciated.

    Kind Regards,
    Daniel

Viewing 15 replies - 1 through 15 (of 30 total)
  • Author
    Replies
  • #17442
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Hello.

    Could you show Composer errors you got during installation of OroCRM?

    As for Bitnami container – can’t tell you for sure because container was built by Bitnami team, not by us.
    If you want to find out the reason you should try to do “cache:clear –no-warmup –env=prod” command manually (maybe with -v option for more verbosity) and debug why file can’t be removed.

    #17445
    munszu
    munszu
    Participant

    Hi,

    I managed to solve the issue it was just PHP INTL missing.
    Now I managed to get to the installation, but I get the following under PHP CLI
    “date.timezone setting must be set”
    I checked my php.ini and the time zone is set, as far as I am aware there are no other php versions installed.

    #17446
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Please, check if you have the same php.ini configuration file for CLI and web server environment (usually these are different configs).

    To check this parameter at CLI you can use command:

    #17447
    munszu
    munszu
    Participant

    You were right, I had to edit cli/php.ini as well.
    Now I managed to install, but when I tried to install the ebay package I got an erro when the script run out of memory. So increased it from 1024 to 1560 but this time I got another error:
    http://pastebin.com/MfAawb8T
    Currently the Dashboard is showing 503 html error and most other parts aren’t accessible.

    #17448
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Unfinished installation might leave lock at your installation. Please, check if you have file /app/cache/maintenance_lock, and if you have – remove it, and then try to install package again.

    As for memory limits – sometimes it might take 2Gb+ of memory because of composer usage.

    #17451
    munszu
    munszu
    Participant

    Deleting the maintenance_lock worked, then I tried increasing the allowed memory_size to 3GB, but now I get the following:
    [Fri Apr 01 08:04:46.752728 2016] [:error] [pid 1320] [client 86.150.53.206:55543] PHP Warning: proc_open(): fork failed – Cannot allocate memory in /var/www/orocrm/crm-application/vendor/symfony/symfony/src/Symfony/Component/Process/Process.php on line 283, referer: http://~/install.php/packages/available

    #17454
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Look’s like the same issue. Also, you can try to install ebay package via CLI using oro:package:install command or as a composer dependency (“Installation” section) .

    #17456
    munszu
    munszu
    Participant

    I tried clearing the cache but I got the following:
    PHP Fatal error: Class ‘Eltrino\OroCrmEbayBundle\EltrinoOroCrmEbayBundle’ not found in /var/www/orocrm/crm-application/app/cache/prod/bundles.php on line 93
    Should I try to manually delete the files from the cache?

    #17457
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Yes, probably, you should remove app/cache/prod manually and then check again.

    If it will not help – there might be an issue with autoloading. You can update autoload using “composer dump-autoload” command.

    #17458
    munszu
    munszu
    Participant

    Thank you for your continued support.

    Unfortunately after trying both I still get the same error:
    PHP Fatal error: Class ‘Eltrino\OroCrmEbayBundle\EltrinoOroCrmEbayBundle’ not found in /var/www/orocrm/crm-application/app/cache/prod/bundles.php on line 93
    The page itself doesn’t load anymore.

    #17459
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Do you have this package (eltrino/orocrm-ebay-bundle) in your composer.json?

    #17460
    munszu
    munszu
    Participant

    Doesn’t seem to be the case, composer.json currently looks like this:
    http://pastebin.com/5FPJQwXi

    #17461
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    1) do “composer require eltrino/orocrm-ebay-bundle:2.0.0” (you can use other version instead of 2.0.0)
    2) manually remove cache from /app/cache directory
    3) do “app/console oro:platform:update –force –env=prod”

    #17462
    munszu
    munszu
    Participant

    I tried installing via composer but got the following:
    “[RuntimeException]
    The lock file does not contain require-dev information, run install with the –no-dev option or run update to install those packages.”

    So I tried again with –no-dev, but:
    [Symfony\Component\Console\Exception\RuntimeException]
    The “–no-dev” option does not exist.

    #17464
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Ok, instead of “composer require …” you can manually add this package to composer.json (if it’s not there yet) and then do “composer update”.

Viewing 15 replies - 1 through 15 (of 30 total)

You must be logged in to reply to this topic.