ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

Open-Source CRM software Forums OroPlatform OroPlatform – Security ASSIGN permission for entity

This topic contains 2 replies, has 2 voices, and was last updated by Dmytro Vasylenko Dmytro Vasylenko 2 years, 5 months ago.

  • Creator
    Topic
  • #5854
    Dmytro Vasylenko
    Dmytro Vasylenko
    Participant

    Hi,

    I’m trying to add new entity. Requirement is that this entity should have separate permission for ASSIGN.

    Annotation for this entity looks like

    also tried this

    Manually placing there ASSIGN does not help either.

    What are requirements to make this happen ?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #5871

    Yurii Muratov
    Oro Core

    Hi.
    Do You have this entity in entities list then You edit some role?
    And if this enity exists in list, what permissions there are for this entity?

    Additionaly, try to run php app/console oro:entity-config:update command.

    #5873
    Dmytro Vasylenko
    Dmytro Vasylenko
    Participant

    hi,

    Yes, i’ve it. I see all permissions (VIEW, CREATE, EDIT, DELETE) except ASSIGN. That column is empty for mine entity.

    Tried to run that commend, without it as i understood entity should not appear at the list at all.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.