ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 2 replies, has 2 voices, and was last updated by  Soopadoubled 1 year, 11 months ago.

  • Creator
    Topic
  • #13397

    Soopadoubled
    Participant

    Hi,

    I’m running Oro CRM v1.8 (on Nginx, with rewrites configured).

    Any functionality that appears to rely on the API results in a 404 when trying to access the API.

    Is there anything specific I need to check (rewrites etc) to resolve this?

    Thanks,

    Ian

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #13404

    Rodolfo
    Participant

    Can you please share your nginx config?

    Check if this nginx config is similar with yours:
    http://www.orocrm.com/blog/news/orocrm-installation-on-server-with-nginx-php-fpm

    If you want to get rid of rewrite config you can use this example for production:
    location ~ ^/app\.php(/|$) {
    fastcgi_pass unix:/var/run/php5-fpm.sock;
    fastcgi_split_path_info ^(.+\.php)(/.*)$;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param HTTPS off;
    internal;
    }

    #13430

    Soopadoubled
    Participant

    Hi,

    Thanks for the response – it was a Nginx issue.

    My configuration conflicted with the main Nginx configuration maintained by my web host. I spoke to them and they configured things for me – issue resolved.

    I would share the specifics but I’m afraid I don’t have access to them.

    Thanks,

    Ian

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.