Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 36 replies, has 3 voices, and was last updated by Ayushi Sangal Ayushi Sangal 3 years, 2 months ago.

  • Creator
    Topic
  • #5468
    Ayushi Sangal
    Ayushi Sangal
    Participant

    Hello,

    I am trying to install OroPlatform on server and results into an error (Allowed memory size of 536870912 bytes exhausted (tried to allocate 72 bytes)) on installing dependencies.

Viewing 15 replies - 1 through 15 (of 36 total)
  • Author
    Replies
  • #5471
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Hello, Ayushi Sangal.

    Yes, it’s known issue – composer requires really big amount of memory for initial install. If you have strict memory restriction, you can use installation with already downloaded dependencies from here http://www.orocrm.com/download. There are links to archives in zip, tar.gz and tar.bz2 formats – these archives already has all dependencies to do installation from scratch.

    #5510
    Dima Soroka
    Dima Soroka
    Oro Core

    Also please make sure you are using latest release (as for today it is 1.3.0) as it has composer.lock file bundled which minimize memory consumption and dependency installation a lot.

    #5511
    Ayushi Sangal
    Ayushi Sangal
    Participant

    Hello,

    Thank you for your help

    I have cloned the official git-hub repository from above link but results into same error again on updating my dependencies. Is this is Something Related to my php.ini Memory limit.

    #5514
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Well, instead of cloning you should download whole installation and unpack it – f.e. this one http://www.orocrm.com/downloads/crm-application.zip. After you’ll do that you already don’t have to run “php composer.phar install –prefer-dist” because all dependencies are already there – instead you should run “php composer.phar run-script post-install-cmd” to set up parameters and execute other installation scripts. After that you can open OroCRM host in browser and continue installation there.

    For server configuration see http://symfony.com/doc/2.3/cookbook/configuration/web_server_configuration.html.

    #5516
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Alternative solution is to change memory_limit in php.ini to -1 (unlimited) and try to run composer install again. But it is not always allowed because OroCRM might be installed on environment with strict memory restriction (f.e. cloud instance).

    #5520
    Ayushi Sangal
    Ayushi Sangal
    Participant

    I am trying to deploy my oro-platform application on server.I have run “php composer.phar run-script post-install-cmd” but got error.

    Class Incenteev\ParameterHandler\ScriptHandler is not autoloadable, can not call post-install-cmd script
    Class Sensio\Bundle\DistributionBundle\Composer\ScriptHandler is not autoloadable, can not call post-install-cmd script

    what can i do regarding this issue.

    #5521
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Please, ensure that vendor directory contains all dependencies, like that:

    If there are no vendors – please, unpack them from archive http://www.orocrm.com/downloads/crm-application.zip

    Also to manually update autoloader you can run “php composer.phar dump-autoload”

    #5522
    Ayushi Sangal
    Ayushi Sangal
    Participant

    Thank you for your help.

    Finally I have vendor now.Now can you let me know step to futhur set it up.

    #5523
    Ayushi Sangal
    Ayushi Sangal
    Participant

    Hello Yevhen,

    I have run “php composer.phar install –prefer-dist” command but there is no installation process.Can you help me regarding this.

    #5525
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    Now you have vendors, next:
    1) php composer.phar dump-autoload – just to ensure that autoloader is correct;
    2) php composer.phar run-script post-install-cmd – it should ask you default parameters, generate app/config/parameters.yml and app/bootstrap.php.cache (if you didn’t do that before)
    3) http://symfony.com/doc/2.3/cookbook/configuration/web_server_configuration.html – set up server configuration (create virtual host and restart server)
    4) open browser and go to your virtual host – and then continue installation from UI (see http://www.orocrm.com/documentation/index/current/book/installation#the-installation)

    #5537
    Ayushi Sangal
    Ayushi Sangal
    Participant

    Thank you for your help.

    #5538
    Ayushi Sangal
    Ayushi Sangal
    Participant

    Hello Yevhen,

    Here Again I am in problem after running “php composer.phar install –prefer-dist” command got few errors.

    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    – The requested package oro/platform could not be found in any version, there may be a typo in the package name.
    Problem 2
    – symfony/icu v1.2.1 requires lib-icu >=4.4 -> the requested linked library icu has the wrong version installed or is missing from your system, make sure to have the extension providing it.
    – symfony/icu v1.2.1 requires lib-icu >=4.4 -> the requested linked library icu has the wrong version installed or is missing from your system, make sure to have the extension providing it.
    – Installation request for symfony/icu v1.2.1 -> satisfiable by symfony/icu[v1.2.1].

    Potential causes:
    – A typo in the package name
    – The package is not available in a stable-enough version according to your minimum-stability

    What should I do to resolve this problem.

    #5540
    Yevhen Shyshkin
    Yevhen Shyshkin
    Oro Core

    > The lock file is not up to date with the latest changes in composer.json
    Probably, you have latest master branch with dependencies from archive – problem is that master is continuously updating, so dependencies are also changing. Please, remove whole application that you cloned from github and extract these files from archive. Then you can run composer install, result should look like this:

    If you want to work with latest master you have to increase your memory limit. In this case you can clone github repository and run composer install there.

    #5541
    Ayushi Sangal
    Ayushi Sangal
    Participant

    okay thank you :)

    #5548
    Ayushi Sangal
    Ayushi Sangal
    Participant

    My php ini memory is set to 252m.can you please tell me how much i should increase to install my dependencies properly.

Viewing 15 replies - 1 through 15 (of 36 total)

You must be logged in to reply to this topic.

ssossossosso