ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 8 replies, has 3 voices, and was last updated by ishakuta ishakuta 4 years, 1 month ago.

  • Creator
    Topic
  • #883

    brentwpeterson
    Participant

    I am getting this error after I ran the most recent update

    PHP Fatal error: Class ‘JDare\\ClankBundle\\JDareClankBundle’ not found in /home/orocrm/html/app/AppKernel.php on line 38, referer: http://orocrm.wagento.com/


    Brent W Peterson
    Magento Evangelist

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #885

    Alexandr Smaga
    Participant

    Hello, seems that you did not run composer update after getting new version of CRM

    #887

    brentwpeterson
    Participant

    Ahhh!! Thank you


    Brent W Peterson
    Magento Evangelist

    #889

    brentwpeterson
    Participant

    I was able to get past that error, but I get this now

    [Tue Sep 24 11:54:58 2013] [error] [client 174.53.200.47] PHP Fatal error: Uncaught exception ‘PDOException’ with message ‘SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘orocrm.oro_session’ doesn’t exist’ in /home/orocrm/html/vendor/symfony/symfony/src/Symfony/Component/HttpFoundation/Session/Storage/Handler/PdoSessionHandler.php:186\nStack trace:\n#0 /home/orocrm/html/vendor/symfony/symfony/src/Symfony/Component/HttpFoundation/Session/Storage/Handler/PdoSessionHandler.php(186): PDOStatement->execute()\n#1 /home/orocrm/html/app/cache/prod/classes.php(409): Symfony\\Component\\HttpFoundation\\Session\\Storage\\Handler\\PdoSessionHandler->write(‘dalt2ciqqh5rl6d…’, ‘_sf2_attributes…’)\n#2 [internal function]: Symfony\\Component\\HttpFoundation\\Session\\Storage\\Proxy\\SessionHandlerProxy->write(‘dalt2ciqqh5rl6d…’, ‘_sf2_attributes…’)\n#3 [internal function]: session_write_close()\n#4 {main}\n\nNext exception ‘RuntimeException’ with message ‘PDOException was thrown when trying to write the session data: SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘orocrm.oro_session’ does in /home/orocrm/html/vendor/symfony/symfony/src/Symfony/Component/HttpFoundation/Session/Storage/Handler/PdoSessionHandler.php on line 209


    Brent W Peterson
    Magento Evangelist

    #890

    Alexandr Smaga
    Participant

    In this release we decided to use database session storage, so you have to update your database. Try to run doctrine:schema:update –force

    #891

    brentwpeterson
    Participant

    Ok that worked now this

    [Tue Sep 24 12:10:08 2013] [error] [client 174.53.200.47] PHP Warning: require(/home/orocrm/html/app/cache/prod/doctrine/orm/Proxies/__CG__OroBundleUserBundleEntityAcl.php): failed to open stream: No such file or directory in /home/orocrm/html/vendor/doctrine/orm/lib/Doctrine/ORM/Proxy/ProxyFactory.php on line 92
    [Tue Sep 24 12:10:08 2013] [error] [client 174.53.200.47] PHP Fatal error: require(): Failed opening required ‘/home/orocrm/html/app/cache/prod/doctrine/orm/Proxies/__CG__OroBundleUserBundleEntityAcl.php’ (include_path=’.:/usr/share/pear:/usr/share/php’) in /home/orocrm/html/vendor/doctrine/orm/lib/Doctrine/ORM/Proxy/ProxyFactory.php on line 92


    Brent W Peterson
    Magento Evangelist

    #893

    Alexandr Smaga
    Participant

    hm… Please, try to clean cache by running rm -rf app/cache/* and set correct permissions by chmod 777 -R app/cache app/emails app/logs web/js web/bundles web/css, also please take into account that this was alfa release and update may brake installation. So better way to re install whole system..

    #906

    brentwpeterson
    Participant

    Ok do I have to drop my database or can I use the already populated one?


    Brent W Peterson
    Magento Evangelist

    #909
    ishakuta
    ishakuta
    Participant

    It’s better to drop db and re-create it, at least while alpha.
    Usually it’s common practice to run all commands that asmaga mentioned after upgrade.

    If doctrine:schema:update –force was able to update your existing db – you should be able to run upgraded system with your already populated db.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.