ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 8 replies, has 4 voices, and was last updated by Mike Kudelya Mike Kudelya 8 months, 2 weeks ago.

  • Creator
    Topic
  • #23558
    Kelvin Kyaw
    Kelvin Kyaw
    Participant

    Hello,

    I have a problem that apache configuration. Here my virtual host setting.

    But, when I access to other menus, http://orocrm.75cl.sg/oro/web/app.php/ is always shown in front of the my targeted menu. So, it was shown 404 page. e.g http://orocrm.75cl.sg/oro/web/app.php/magento/cart/. It should be like that http://orocrm.75cl.sg/app.php/magento/cart/

    I just follow this instruction. I think that instruction have some typo error the following two line.

    Please help me to fix it this issue.

    Regards,
    Kelvin

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #23566
    wwsh
    wwsh
    Participant

    Looks like you don’t have the rewrite module enabled in Apache. Do you?

    #23567
    Kelvin Kyaw
    Kelvin Kyaw
    Participant

    Here my enabled module

    #23650
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi

    Here is my virtual host and i successfully open http://orocrm-application.local/app_dev.php:

    I think http://orocrm.75cl.sg/oro/web/app.php is wrong url. Your document root already has been set to
    /oro/web, why do you add /oro/web to your url ? Try http://orocrm.75cl.sg/app.php

    #29172

    bradley.semple
    Participant

    Hi there

    I am having the same issue. Here are the details;

    document root is /var/www/html/orocrm/web

    In my .conf file for this virtual host i have this set in the documentRoot as well as in the <Directory> ie <Directory /var/www/html/orocrm/web>

    My url us crm.example.com. This works fine and i can log in and see the dashboard. But when selecting logout or perhaps going to a menu item like jobs it comes up like this

    crm.example.com/app.php/orocrm/web/app.php/message-queue/jobs
    rather than
    crm.example.com/app.php/message-queue/jobs.

    If i remove the extra documentRoot info from the URL it works fine, so I am sure its an apache thing.

    My virtual host file looks the same as Kelvin Kyaw with the extra option of “Allow from all” in my Directory options.

    Any help would be great as i really want to get stuck into using OroCRM.

    #29173

    bradley.semple
    Participant

    I have also just noticed that if i go to app_dev.php manually or set it as the DocumentIndex, the issue goes away… if i change back to app.php, issues happen again.

    Thanks in advance

    #29176
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Hi

    Issue still appear when will you run this commands?

    #29180

    bradley.semple
    Participant

    Yes it does

    Here is my apache config and i have confirmed that MOD_REWRITE has been enabled and I am only running 1 version of PHP, version 7.0.

    The only thing i can think of that i did different from the install was using composer from the Ubuntu Software reop as well as the nodejs from Ubuntu Repo. I am running Ubuntu 16.04.1 LTS

    Thanks again

    #29679
    Mike Kudelya
    Mike Kudelya
    Oro Core

    Try to find differences between my and your configuration. This config is working on orocrm 1.9.*, 1.10.*, 2.0. I’m using apache 2.2.31, php 7.0. .htaccess file in web folder i leave default.

    Here is my vhosts.conf:

    Here is my httpd.conf:

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.