ssossossosso
 RSS

orocrm-rc

 

OroCRM Release Candidate 2 and OroPlatform Release Candidate 3 are now available! With this release we are one step closer to our first stable release of our application OroCRM the Open Source CRM for Commerce.

This release adds the following features and enhancements:

  • Package Manager – This is a BAP feature that provides user interface for managing packages – a separate application that allows to view installed packages, check for available packages, install new packages and disable ones that are installed.
  • Refactored Flexible Workflows – Simplify creation and management of the complex workflows that have more than one related entity.
  • Embedded Forms – This feature allows developers to create embedded forms that can be used in third-party websites in order to collect data directly into OroCRM and have workflows around the data collected. A package with a Magento Contact-Us form is also available with this release.
  • Account Merging – Users will now be able to merge up to 5 account records at a time into one account, with a simple and easy-to-use GUI tool.
  • CSV Export – The ability to export data grids to CSV files has been added to custom reports and most data grids.
  • Upgrading – We have added the ability to upgrade existing installations of OroCRM. To upgrade follow the instructions in UPGRADE.md file. In future releases this process will be automated.

 

To learn more about the existing and upcoming features visit our Features and Roadmap pages.

Clone instruction can be found here.

All issues should be reported in GitHub:

If you have an issue with the OroPlatform, please report it to our OroPlatform GitHub page. And If you run into an issue with OroCRM, please report it to our OroCRM GitHub page.

As always, we look forward to hearing your feedback and comments in our forums

Tags:

2 comments
  1. Problem 2
    – oro/platform 1.0.0-rc3 requires willdurand/expose-translation-bundle 1.1.* -> no matching package found.
    – oro/crm-magento-embedded-contact-us 1.0.0-rc1 requires oro/platform 1.0.0-rc3 -> satisfiable by oro/platform[1.0.0-rc3].
    – Installation request for oro/crm-magento-embedded-contact-us 1.0.0-rc1 -> satisfiable by oro/crm-magento-embedded-contact-us[1.0.0-rc1].

  2. When trying to install i’m getting following composer errors:

    Problem 1
    – Installation request for oro/platform 1.0.0-rc3 -> satisfiable by oro/platform[1.0.0-rc3].
    – oro/platform 1.0.0-rc3 requires willdurand/expose-translation-bundle 1.1.* -> no matching package found.